Deciphering
Glyph
( )
Don't Use Python 2.5 Just Yet

Sat 04 November 2006

... especially if you use Windows.


A few people installing Python for Windows just asked me if they should be using Python 2.5 or 2.4. I was unpleasantly surprised to recall it should be the latter. There's no release of Twisted that works with Python 2.5 yet. Not only that, but with Twisted trunk, although many 2.5 issues have been fixed, there are still some problems with the way that the command line tools start up on Windows which makes it impossible to even run the tests, let alone see whether they succeed.


You can keep track of this by looking at the Twisted buildbots page and the "win32-py2.5-select" buildbot in particular.


For now, though, if you want to use Twisted on Windows, you'll need Python 2.4.4. You can download it from the 2.4.4 release page on python.org.